$re = '/^(?=.{1,20}$)[A-Za-z]+(?:[ \'-][A-Za-z]+)?$/m';
$str = 'John Doe
John-Doe
John\'Doe
-JohnDoe
John Doe-
\'John Doe
John Doe\'
John--Doe
John\'\'Doe
John Doe
John\'-Doe
John\' Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);