re = /^(?=.{1,20}$)[A-Za-z]+(?:[ '-][A-Za-z]+)?$/m
str = 'John Doe
John-Doe
John\'Doe
-JohnDoe
John Doe-
\'John Doe
John Doe\'
John--Doe
John\'\'Doe
John Doe
John\'-Doe
John\' Doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end