import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[.*\\]\\n+((?:;;.*\\n+)+)";
final String string = "[TITLE]\n\n"
+ "[OPTIONS]\n"
+ ";;Options Value\n"
+ ";;------------------ ------------\n"
+ "FLOW_UNITS CFS\n"
+ "<MORE TEXT>\n\n"
+ "[PATTERNS]\n"
+ ";;Name Type Multipliers\n"
+ ";;-------------- ---------- -----------\n"
+ ";Daily pattern generated from time series '2-166:2-165 (obs)'. Average value was 0.0485 MGD.\n"
+ "2-166:2-165_(obs)_Daily DAILY 1.011 1.008 1.06 0.908 1.072 0.998 0.942\n"
+ "<MORE TEXT>\n\n"
+ "[COORDINATES]\n"
+ ";;Node X-Coord Y-Coord \n"
+ ";;-------------- ---------------- ----------------\n"
+ "<MORE TEXT>\n\n"
+ "[JUNCTIONS]\n"
+ ";; Invert Max. Init. Surcharge Ponded \n"
+ ";;Name Elev. Depth Depth Depth Area \n"
+ ";;-------------- ---------- ---------- ---------- ---------- ----------\n"
+ "1-1 837.85 15.25 0 0 0 \n"
+ "<MORE TEXT> \n\n"
+ "[REPORT]\n"
+ "INPUT YES\n"
+ "CONTROLS NO\n"
+ "<MORE TEXT>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}