# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[.*\]\n+((?:;;.*\n+)+)"
test_str = ("[TITLE]\n\n"
"[OPTIONS]\n"
";;Options Value\n"
";;------------------ ------------\n"
"FLOW_UNITS CFS\n"
"<MORE TEXT>\n\n"
"[PATTERNS]\n"
";;Name Type Multipliers\n"
";;-------------- ---------- -----------\n"
";Daily pattern generated from time series '2-166:2-165 (obs)'. Average value was 0.0485 MGD.\n"
"2-166:2-165_(obs)_Daily DAILY 1.011 1.008 1.06 0.908 1.072 0.998 0.942\n"
"<MORE TEXT>\n\n"
"[COORDINATES]\n"
";;Node X-Coord Y-Coord \n"
";;-------------- ---------------- ----------------\n"
"<MORE TEXT>\n\n"
"[JUNCTIONS]\n"
";; Invert Max. Init. Surcharge Ponded \n"
";;Name Elev. Depth Depth Depth Area \n"
";;-------------- ---------- ---------- ---------- ---------- ----------\n"
"1-1 837.85 15.25 0 0 0 \n"
"<MORE TEXT> \n\n"
"[REPORT]\n"
"INPUT YES\n"
"CONTROLS NO\n"
"<MORE TEXT>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.