using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href=\"")[^\""]+";
string input = @"<li id=""n-mainpage-description""><a href=""/wiki/Main_Page"" title=""Visit the main page [z]"" accesskey=""z"">Main page</a></li>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}