re = /(?<=href=\")[^\"]+/m
str = '<li id="n-mainpage-description"><a href="/wiki/Main_Page" title="Visit the main page [z]" accesskey="z">Main page</a></li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end