const regex = /(?!<p\s*+class="translate")<p[^>]*+>[^<>]*+<\Kstrong/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<p\\s*+class="translate")<p[^>]*+>[^<>]*+<\\Kstrong', 'gm')
const str = `<p class="translate" style="font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;"><strong><span style="color: blue;">Lorem</span><br><span style="color: navy;">ipsum</span></strong>
</p></div>
<p style="font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;"><strong><span style="color: blue;">Lorem</span><br><span style="color: navy;">ipsum</span></strong>
</p>
stronger
strongest
<span style="color:blue;font-weight:bold;">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}