import re
regex = re.compile(r"(?!<p\s*+class=\"translate\")<p[^>]*+>[^<>]*+<\Kstrong", flags=re.MULTILINE)
test_str = ("<p class=\"translate\" style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
"</p></div>\n"
"<p style=\"font-size: 15px; color: black; line-height: 18px; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: transparent; font-family: Verdana; text-align: right;\"><strong><span style=\"color: blue;\">Lorem</span><br><span style=\"color: navy;\">ipsum</span></strong>\n"
"</p>\n"
"stronger\n"
"strongest\n"
"<span style=\"color:blue;font-weight:bold;\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")