$re = '/(https:\/\/)?(www\.)?github\.com\/[A-Za-z0-9_-]+\/?/m';
$str = 'www.github.com/helloman
https://www.github.com/helloman
https://github.com/helloman
github.com/xxx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);