// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https:\/\/)?(www\.)?github\.com\/[A-Za-z0-9_-]+\/?").unwrap();
let string = "www.github.com/helloman
https://www.github.com/helloman
https://github.com/helloman
github.com/xxx
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}