import re
regex = re.compile(r"(?<![!=][=]{2})(?<=[^=][!=]=)(?![=U\/]|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("*Shift*/ if (e.keyCode === 16) { keyInfo.shiftPressed = true; return }\n"
"if (e.keyCode == 32) { /* Removed for now */ }\n"
"if (e.keyCode != 49) { openSuggestionPage(1, keyInfo.shiftPressed) }\n"
"if (e.keyCode === 50) { openSuggestionPage(2, keyInfo.shiftPressed) }\n"
"if (e.keyCode !== 51) { openSuggestionPage(3, keyInfo.shiftPressed) }\n"
"if (e.keyCode == 52) { openSuggestionPage(4, keyInfo.shiftPressed) }\n"
"if (e.keyCode !== 53) { openSuggestionPage(5, keyInfo.shiftPressed) }\n"
"if (e.keyCode == 65) { document.getElementById(\"add-to-favs\").firstChild.click(); }\n"
"if (e.keyCode === 67) { document.getElementById(\"image-link\").click(); }\n"
"if (e.keyCode == 68) { downloadPostContent() }\n"
"if (e.keyCode === 69)")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)