const regex = new RegExp('^(?!.{15}$)(?!.{17}$)[0-9]{13,20}$', 'gm')
const str = `1
22
333
4444
55555
666666
7777777
88888888
999999999
1010101010
11111111111
121212121212
1313131313131
14141414141414
151515151515151
1616161616161616
17171717171717171
181818181818181818
1919191919191919191
20202020202020202020
212121212121212121212
2222222222222222222222
23232323232323232323232
242424242424242424242424
2525252525252525252525252`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}