re = /^(?!.{15}$)(?!.{17}$)[0-9]{13,20}$/m
str = '1
22
333
4444
55555
666666
7777777
88888888
999999999
1010101010
11111111111
121212121212
1313131313131
14141414141414
151515151515151
1616161616161616
17171717171717171
181818181818181818
1919191919191919191
20202020202020202020
212121212121212121212
2222222222222222222222
23232323232323232323232
242424242424242424242424
2525252525252525252525252'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end