using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\$(?:[^(\$\$)\\]|\\.)*\$\$";
string input = @"هذا اختبار $$الفراغات$$، يجب علينا اختبار سؤال $$الفراغات$$ $$فراغ$$
fill this $$blanks$$ and be $$aw sd%^^a re$$";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}