re = /\$\$(?:[^(\$\$)\\]|\\.)*\$\$/
str = 'هذا اختبار $$الفراغات$$، يجب علينا اختبار سؤال $$الفراغات$$ $$فراغ$$
fill this $$blanks$$ and be $$aw sd%^^a re$$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end