using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\S*(?:\s(?!\()\S*)*";
string input = @"Isla Vista (University of California, Santa Barbara)[2]
Carrollton (University of West Georgia)[2]
Dahlonega (North Georgia College & State University)[2]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}