re = /^\S*(?:\s(?!\()\S*)*/m
str = 'Isla Vista (University of California, Santa Barbara)[2]
Carrollton (University of West Georgia)[2]
Dahlonega (North Georgia College & State University)[2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end