$re = '/(?<!\d)(\d{1,3}(?:,\d{3})+)(?!\d)/m';
$str = '10,000 to 150,000,000 150,100,111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);