re = /(?<!\d)(\d{1,3}(?:,\d{3})+)(?!\d)/m
str = '10,000 to 150,000,000 150,100,111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end