using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Blok |No\.)(?:\d|\w)-?(?:\w|\d)?";
string input = @"Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A
Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A
G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}