import Foundation
let pattern = #"(?<=Blok |No\.)(?:\d|\w)-?(?:\w|\d)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Jl. Gotong Royong 1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A Kapuk, Cengkareng
Jl. Gotong Royong 1 No.3A
Jl. Gotong Royong 1 Blok M No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok M-1 No.3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A, Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A Kapuk, Cengkareng
Jl. Gotong Royong 1 Blok 3A
G-Land Padalarang Residence Blok C No.1, Jayamekar, Padalarang
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)