re = /^(\s*|(([^,:&]*[^,:&\s]+[^,:&]*)+:[^,:&]*,)*(([^,:&]*[^,:&\s]+[^,:&]*)+:[^,:&]*,?))$/m
str = 'url_domain:keskustelu.suomi24.fi,url_path:/matkailu/matkakohteet/aasia,layout:lg,categories:Matkailu,main_category:Matkailu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end