using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)-(.{2})(?=-game-play)";
string input = @"cricket-ck-game-play
hand-ball-hb-game-play
volley-ball-vb-game-play
soccer-sc-game-play";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}