const regex = /(.*)-(.{2})(?=-game-play)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)-(.{2})(?=-game-play)', 'gm')
const str = `cricket-ck-game-play
hand-ball-hb-game-play
volley-ball-vb-game-play
soccer-sc-game-play`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}