import re
regex = re.compile(r"^Start .*(?:\r?\n(?!\r?\n).*)*", flags=re.MULTILINE)
test_str = ("....\n"
"Dummyline\n\n"
"Start of matching\n"
"+----------+----------------------------+\n"
"+ test + 1234 +\n"
"+ test2 + 5678 +\n"
"+----------+----------------------------+\n\n"
"Finish above. Do not match this\n"
"+----------+----------------------------+\n"
"+ dummy1 + 00000000000 +\n"
"+ dummy2 + 12345678910 +\n"
"+----------+----------------------------+")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")