re = /^Start .*(?:\r?\n(?!\r?\n).*)*/m
str = '....
Dummyline
Start of matching
+----------+----------------------------+
+ test + 1234 +
+ test2 + 5678 +
+----------+----------------------------+
Finish above. Do not match this
+----------+----------------------------+
+ dummy1 + 00000000000 +
+ dummy2 + 12345678910 +
+----------+----------------------------+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end