using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?<object|<video[^>]*((?<=movieId_)\d+|(?<=movie)\d+)";
string input = @"<video id=""movie1"" class=""show_movie-camera animation_target movieBorder hasAudio movieId_750"" src=""/path/to/movie"" style=""position: absolute; z-index: 505; top: 44.5px; left: 484px; display: none;"" preload=""true"" autoplay=""true""></video>
<video id=""movie2"" class=""clickInfo movieId_587"" src=""/path/to/movie"" preload=""true"" autoplay=""true""></video>
<video id=""movie300"" src=""/path/to/movie"" preload=""true"" autoplay=""true""></video>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}