re = /.*?<object|<video[^>]*((?<=movieId_)\d+|(?<=movie)\d+)/m
str = '<video id="movie1" class="show_movie-camera animation_target movieBorder hasAudio movieId_750" src="/path/to/movie" style="position: absolute; z-index: 505; top: 44.5px; left: 484px; display: none;" preload="true" autoplay="true"></video>
<video id="movie2" class="clickInfo movieId_587" src="/path/to/movie" preload="true" autoplay="true"></video>
<video id="movie300" src="/path/to/movie" preload="true" autoplay="true"></video>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end