import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?<object|<video[^>]*\\K(?:hasAudio[^>]*\\K(?:(?<=movieId_)\\d+|(?<=movie)\\d+)|(?:(?<=movieId_)\\d+|(?<=movie)\\d+)(?=[^>]*hasAudio))";
final String string = "<video id=\"movie1\" class=\"show_movie-camera animation_target movieBorder hasAudio movieId_750\" src=\"/path/to/movie\" style=\"position: absolute; z-index: 505; top: 44.5px; left: 484px; display: none;\" preload=\"true\" autoplay=\"true\"></video>\n"
+ "<video id=\"movie2\" class=\"clickInfo movieId_587\" src=\"/path/to/movie\" hasAudio preload=\"true\" autoplay=\"true\"></video>\n"
+ "<video id=\"movie300\" src=\"/path/to/movie\" preload=\"true\" autoplay=\"true\"></video>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}