# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?<object|<video[^>]*\K(?:hasAudio[^>]*\K(?:(?<=movieId_)\d+|(?<=movie)\d+)|(?:(?<=movieId_)\d+|(?<=movie)\d+)(?=[^>]*hasAudio))"
test_str = ("<video id=\"movie1\" class=\"show_movie-camera animation_target movieBorder hasAudio movieId_750\" src=\"/path/to/movie\" style=\"position: absolute; z-index: 505; top: 44.5px; left: 484px; display: none;\" preload=\"true\" autoplay=\"true\"></video>\n"
"<video id=\"movie2\" class=\"clickInfo movieId_587\" src=\"/path/to/movie\" hasAudio preload=\"true\" autoplay=\"true\"></video>\n"
"<video id=\"movie300\" src=\"/path/to/movie\" preload=\"true\" autoplay=\"true\"></video>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.