# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s).*?(<div id="start">.*?<div id="end">)(?:(?:(?!<div id="start">).)*$)?/$1\n\n/gm;t' <<< "Stuff I dont need before
<div id=\"start\">
blablabla11
blablabla12
<div id=\"end\">
Stuff I dont need in the middle
<div id=\"start\">
blablabla21
blablabla22
<div id=\"end\">
Stuff I dont need in the middle2
<div id=\"start\">
blablabla31
blablabla32
<div id=\"end\">
Stuff I dont need in the end"