re = /(?s).*?(<div id="start">.*?<div id="end">)(?:(?:(?!<div id="start">).)*$)?/m
str = 'Stuff I dont need before
<div id="start">
blablabla11
blablabla12
<div id="end">
Stuff I dont need in the middle
<div id="start">
blablabla21
blablabla22
<div id="end">
Stuff I dont need in the middle2
<div id="start">
blablabla31
blablabla32
<div id="end">
Stuff I dont need in the end'
subst = '$1\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result