import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(fstype=\"[^\"]*\").*?(instance=\"[^\"]*\").*?(mountpoint=\"[^\"]*\").*";
final String string = "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.10:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-xvz7v\", service=\"prometheus-prometheus-node-exporter\"}\n"
+ "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.11:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-w8cqq\", service=\"prometheus-prometheus-node-exporter\"}\n"
+ "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.12:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-4wfhq\", service=\"prometheus-prometheus-node-exporter\"}\n"
+ "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.13:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-zfskj\", service=\"prometheus-prometheus-node-exporter\"}\n"
+ "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.15:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-cllnv\", service=\"prometheus-prometheus-node-exporter\"}";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}