// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).*(fstype="[^"]*").*?(instance="[^"]*").*?(mountpoint="[^"]*").*"#).unwrap();
let string = "{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.10:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-xvz7v\", service=\"prometheus-prometheus-node-exporter\"}
{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.11:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-w8cqq\", service=\"prometheus-prometheus-node-exporter\"}
{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.12:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-4wfhq\", service=\"prometheus-prometheus-node-exporter\"}
{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.13:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-zfskj\", service=\"prometheus-prometheus-node-exporter\"}
{container=\"node-exporter\", device=\"/dev/mapper/ubuntu--vg-ubuntu--lv\", endpoint=\"http-metrics\", fstype=\"ext4\", instance=\"172.20.32.15:9100\", job=\"node-exporter\", mountpoint=\"/\", namespace=\"prometheus\", pod=\"prometheus-prometheus-node-exporter-cllnv\", service=\"prometheus-prometheus-node-exporter\"}";
let substitution = "$1 $2 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}