package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9][^SLOIBZsloibz0-9][^SLOIBZsloibz][0-9]-?[^SLOIBZsloibz0-9][^SLOIBZsloibz][0-9]-?[^SLOIBZsloibz0-9][^SLOIBZsloibz0-9][0-9][0-9]$`)
var str = `1EG4-TE5-MK73
1EG4TE5MK73
1SG4-TE5-MK73
0EG4-TE5-MK73`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}