$re = '/(\d{4}[-.()\/* ]*(?:(?:x|ext)[:]?[ ]*\d+)?)/m';
$str = '8910 ext 234
1234 x 5
2345 x 019234
2345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);