import re
regex = re.compile(r"(\d{4}[-.()\/* ]*(?:(?:x|ext)[:]?[ ]*\d+)?)", flags=re.MULTILINE)
test_str = ("8910 ext 234\n"
"1234 x 5\n"
"2345 x 019234\n"
"2345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")