import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\W)I{1,3}(?!\\w)";
final String string = "TEST I \n\n"
+ "TEST II\n\n"
+ "TEST III\n\n"
+ "STRINGENDINGINI III \n\n"
+ "ANOTHER TEST II\n\n"
+ "ANOTHERI TESTI III\n\n"
+ "Results for these should be\n\n"
+ "I \n\n"
+ "II\n\n"
+ "III\n\n"
+ "III\n\n"
+ "II\n\n"
+ "III";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}