$re = '/(?<=\W)I{1,3}(?!\w)/';
$str = 'TEST I
TEST II
TEST III
STRINGENDINGINI III
ANOTHER TEST II
ANOTHERI TESTI III
Results for these should be
I
II
III
III
II
III';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);