using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\+?0*610?(\d{3})(\d{3})(\d{4})(?!\d).*$";
string substitution = @"+61 (0) $1 $2 $3";
string input = @"xgsh6101231231234vvajxxgsh6101231231234vvajx
xgsh06101231231234vvajx
xgsh000006101231231234vvajx
+6101231231234
xgsh61012312312345vvajx
xgsh5101231231234vvajx
xgsh00000101231231234vvajx
xgsh6143545626455345601231231234vvajx
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}