# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\+?0*610?(\d{3})(\d{3})(\d{4})(?!\d).*$"
test_str = ("xgsh6101231231234vvajxxgsh6101231231234vvajx\n"
"xgsh06101231231234vvajx\n"
"xgsh000006101231231234vvajx\n"
"+6101231231234\n"
"xgsh61012312312345vvajx\n"
"xgsh5101231231234vvajx\n"
"xgsh00000101231231234vvajx\n"
"xgsh6143545626455345601231231234vvajx\n")
subst = "+61 (0) $1 $2 $3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.