package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\S+`)
var str = `This is a #tag and this is another #love@irc.oftc.net and more text.
This is a 1234#tag and this is another sometext#love@irc.oftc.net and more text.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}