re = /#\S+/
str = 'This is a #tag and this is another #love@irc.oftc.net and more text.
This is a 1234#tag and this is another sometext#love@irc.oftc.net and more text.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end