package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w*[A-Za-z]\w*\b`)
var str = `Hello world one 12345w more 12345 of the 789 same wor123ld
he11o
123
wor123
123world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}