$re = '/\b\w*[A-Za-z]\w*\b/m';
$str = 'Hello world one 12345w more 12345 of the 789 same wor123ld
he11o
123
wor123
123world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);