const regex = /(?:\),\(\d{1,4},|,\d{10},)(*SKIP)(?!)|./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\),\\(\\d{1,4},|,\\d{10},)(*SKIP)(?!)|.', 'g')
const str = `Text ),(1234, and more ,0123456789, here
),(39,' ',1,'01761472100','@','9 ','20',1237213277,0,1237215419,''),(40,' ',3,'01445731203','@',' ','-','22 2','210410//816',1237225423,0,1484651768,''),(4270,' /`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);