package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s*([^][]*?)\s*]`)
var str = `hello this is an example [ a b c ]
hello this is another example [ cat bird dog elephant ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}