$re = '/\[\s*([^][]*?)\s*]/m';
$str = 'hello this is an example [ a b c ]
hello this is another example [ cat bird dog elephant ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);