#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)C:\\File Transfer\\Relay Files\\8Series_files\\(?<your_field>[^\\]+)\\WB_CWP8_869\\evt\.txt"
Local $sString = "C:\File Transfer\Relay Files\8Series_files\WB-CWP\WB_CWP8_869\evt.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")