$re = '/Building\D*\b([\d.]+)/m';
$str = 'Building 38 House 10
Building : 10.5 house 900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);